• اطلاعیه ها

    • Masih

      برخوردی شدید با تاپیک های تبلیغاتی   شنبه, 12 آبان 1397

      درود، از این لحظه به بعد، تمامی تاپیک های تبلیغاتی سبک رپرتاژ که با هدف جمع آوری بک لینک در انجمن های بیست اسکریپت ایجاد می شوند، حذف شده و دسترسی کاربر خاطی نیز مسدود خواهد شد.
hamedi

نصب تالار ips

5 ارسال در این موضوع قرار دارد

سلام. برای مشکل نصب نشدن ips به پشتیبانی اطلاع دادم. گفتن که نیم ساعت روی مسئله کار کردن نهایتا خودشون نصبش کردن ولی دیگه نمیتونم ورژن پی اچ پی رو تغییر بدم و برای همیشه روی 5.6 native میمونه.

آخرین پاسخشون به مشکل قفل شدن پی اچ پی روی نسخه 5.6 این بود که : محدودیت های کلاد لینوکس رو برای سایت من غیرفعال کردن و بخاطر همین دیگه امکان استفاده از php selector وجود نخواهد داشت.

به نظرتون اشکالی نداره که پی اچ پی روی 5.6 میمونه؟  به نظرتون سایت وردپرسی و در کنارش انجمن رو روی همین نسخه نگه دارم مشکلی نداره؟

در هنگام نصب دوباره انجمن این پیغام هم ظاهر شد که من ادامه دادم و نصب کردم. یعنی ممکنه این توصیه برای بعدا باعث ایجاد مشکل جدی بشه؟ 

لطفا راهنمایی کنید.

 

توصیه ها

موارد زیر هم اکنون برای ادامه عملیات نصب نیاز نیست ولی برای نسخه بعدی IPS حتما لازم هستند. حتما موارد زیر را به اطلاع پشتیبانی سرور خود برسانید تا در آینده دچار مشکل نشوید. هر زمان که تمایل داشتید با مراجعه به بخش پشتیبانی در مدیریت می توانید این موارد را مجددا بررسی نمایید.

·        نسخه PHP نصب شده شما 5.6.36 می باشد. هر چند این نسخه قابل استفاده می باشد ولی توصیه می شود از نسخه 7.0.0 یا بالاتر استفاده نمایید.

·        مقدار suhosin.get.max_value_length در PHP بر روی 512 تنظیم شده است. متاسفانه این مقدار باعث ایجاد مشکلات حادی در بعضی از بخش های IPS می شود. توصیه می کنیم مقدار آن به 2000 تغییر یابد.

·        مقدار suhosin.request.max_varname_length در PHP بر روی 64 تنظیم شده است. متاسفانه این مقدار باعث ایجاد مشکلات حادی در بعضی از بخش های IPS می شود. توصیه می کنیم مقدار آن به 350 تغییر یابد.

 

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

درود.

نقل قول

به نظرتون اشکالی نداره که پی اچ پی روی 5.6 میمونه؟  به نظرتون سایت وردپرسی و در کنارش انجمن رو روی همین نسخه نگه دارم مشکلی نداره؟

خیر دوست عزیز مشکلی پیش نمیاد. اکثر اسکریپت های جدید به خوبی با PHP 5.6 سازگار هستند. اسکریپت های بسیار قدیمی ممکنه مشکل داشته باشند و نتونند روی 5.6 اجرا بشن، یا برخی اسکریپت های خیلی خاص، نیازمند 7.0 به بالا باشند وگرنه کار نخواهند کرد.

اما در حالت عادی نسخه 5.6 PHP مناسب برای اکثر اسکریپت هاست.

 

نقل قول

آخرین پاسخشون به مشکل قفل شدن پی اچ پی روی نسخه 5.6 این بود که : محدودیت های کلاد لینوکس رو برای سایت من غیرفعال کردن و بخاطر همین دیگه امکان استفاده از php selector وجود نخواهد داشت.

والا تاحالا ندیده بودم هاستینگی برای جلوگیری از بروز مشکلات بعدی، این امکان در پنل هاست رو غیرفعال کنه برای کاربر!! :| شخصا IPS رو برای تعداد زیادی از کاربران روی هاستینگ های مختلف نصب کردم و هیچ گونه مشکلی هم نداشته. عجیبه! o.O

 

نقل قول

در هنگام نصب دوباره انجمن این پیغام هم ظاهر شد که من ادامه دادم و نصب کردم. یعنی ممکنه این توصیه برای بعدا باعث ایجاد مشکل جدی بشه؟ 

خب اگه هاستینگ براتون نصب کرده ، دیگه دلیلی نداشت مجددا خودتون نصب کنید! حتما تغییراتی در اسکریپت یا ماژول های هاستتون دادن تا بتونن نصب کنن.

 

نقل قول

نسخه PHP نصب شده شما 5.6.36 می باشد. هر چند این نسخه قابل استفاده می باشد ولی توصیه می شود از نسخه 7.0.0 یا بالاتر استفاده نمایید.

از لحاظ نسخه PHP مشکلی پیش نخواهد اومد. IPS روی 5.6 به بالا به خوبی کار میکنه.

 

نقل قول

مقدار suhosin.get.max_value_length در PHP بر روی 512 تنظیم شده است. متاسفانه این مقدار باعث ایجاد مشکلات حادی در بعضی از بخش های IPS می شود. توصیه می کنیم مقدار آن به 2000 تغییر یابد.

مقدار پیش فرض suhosin در تمامی کانفیگ های php.ini سرورها 512 هست و به مقادیر بیشتر هم نیازی نیست. این هم که گفته مشکلات حادی پیش میاد، یه احتمال هست. ولی همین 512 هم به خوبی جوابگو هست و مشکلی نیست. ولی اگه منابع سرورتون کم باشه، و گاهی اوقات ارور internal server error گرفتید، به هاستینگ بگید این مقدار رو افزایش بدن.

برای مورد بعدی هم همینطور. مقدار پیش فرض هست و مشکلی نداره مگر اینکه در آینده با فعالیت بیشتر سایتتون قطع و وصل بشه که هاستینگ می تونه با تغییر این مقادیر در php.ini مشکلتون رو حل کنه و نیاز به صرف زمان زیادی نیست.

 

موفق باشید.

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

ارسال شده در (ویرایش شده)

سلام ممنون. قبل از اینکه به سوالم پاسخ بدید مجددا به هاستینگ تیکت زدم که اگه ممکنه نسخه php رو روی 7 بگذارن و بعد قفل بشه و بعبارتی php selector غیرفعال بشه.

ایشون گفتن که این امکان وجود نداره و با خارج کردن سایتم از محدودیت های سرور  نسخه php الزاما روی 5.6 باقی میمونه.

ولی دو اخطاری که در مورد suhosin هست رو برطرف کردن و گفتن که مقدارش رو به مقداری که ips خواسته افزایش دادن. 

راستش فقط نگران یک مورد هستم. اینکه سایت وردپرسیم که در کنار تالار هست بخاطر php 5.6 برای بعدها با مشکل مواجه نخواهد شد؟ توضیحتون در مورد سازگاری اکثر افزونه ها با این نسخه رو متوجه شدم  سوال من برای زمانی هست که شاید php 5.6 جایگاهش میشه مثل 5.2   و این در حالی هست که نسخه 7.2 هم الان وجود داره و نگرانم که شاید برای آپدیت انجمن و یا بروز بودن افزونه های سایت وردپرسیم و یا حتی قالب وردپرس مشکلات بوجود بیاد. در مورد انجمن میتونم دیگه آپدیتش نکنم و همین کافیه منتها همیشه باید مواظب اطلاعاتش باشم که بخاطر اختلالی از دست نرن.

در مورد سایت وردپرسی فکر کنم بیشتر با مشکل مواجه بشم. لطفا راهنمایی کنید. باتشکر.

ویرایش شده در توسط hamedi

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

درود مجدد.

هر نسخه PHP تا یک تاریخ مشخصی عمر قابل قبول داره. بعد از اون تاریخ، همچنان کار می کنه و مشکلی نداره اما بعد از اون تاریخ، اکثر طراحان سعی خواهند کرد کدهاشون رو بر اساس توابع PHP جدیدتر بنویسند.

برای نسخه 5.6 گفته شده که تا

لطفا برای مشاهده link وارد سایت شوید و یا ثبت نام کنید.

عمر خواهد کرد. یعنی 10 دی 1397 شمسی. ولی دلیل نمیشه که بعد از این تاریخ دیگه نشه از این نسخه استفاده کرد. فقط تنها مشکلی که ممکنه پیش بیاد اینه که آپدیت های جدیدتر نیازمند نسخه های بعدی باشه.

نسخه های PHP هم در هر نسخه، توابع متفاوتی ندارند. مثل یک نرم افزار هست که در هر نسخه ممکنه فقط بخش کوچکی از اون تغییر کنه. در نسخه های جدیدتر PHP ، برخی از توابع نسخه های قدیمی به دلایل متفاوت (امنیتی ، سرعت اجرا و ...) تغییر می کنند یا منقضی میشن . پس ممکنه همچنان اسکریپت و وردپرس شما در بروز رسانی های جدیدترشون به کارشون ادامه بدن (البته در صورتی که نسخه 5.6 PHP از سرورتون حذف نشه).

بعد از اتمام عمر PHP 5.6 هاستنگ ها موظف هستند تا به دلیل مشکلات امنیتی، حداقل نسخه PHP سرورهاشون رو به PHP 7.0 ارتقاء بدن. ولی همچنان نسخه های قبلی PHP در اکثر هاستینگ ها در دسترس خواهد بود.

 

 

ولی در کل ، باز هم بخشی از پاسخ قبلم رو تکرار می کنم :

هاست قدرتمند، نباید محدودیتی در انتخاب نسخه PHP داشته باشه!! شخصا تاحالا چند سایت برای دوستان انجمن با اسکریپت های مشابه شما (وردپرس + انجمن ساز IPS یا زنفورو) رو روی نسخه های 7.1 و 7.2 نصب کردم و به راحتی و بدون خطا هم جواب داده. شما بهتره بجای نگرانی در این موضوع، هاستینگ قدرتمندی رو انتخاب کنید که در آینده چنین مشکلاتی نداشته باشید.

 

موفق باشید.

پسند شده توسط 2 کاربر

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

بسیار عالی ممنون از توضیحاتتون. بله ان شاء الله طی روندی که از طریق تیکتها در حال پیگیری هست نهایتا به جایی برسم که بدون نگرانی بتونم کار سایت رو ادامه بدم و طبق فرمایشتون با هاستینگی که منعطف و بروز باشه راندمان و آینده سایت تامین بشه. باتشکر.

به اشتراک گذاری این ارسال


لینک به ارسال
به اشتراک گذاری در سایت های دیگر

برای ارسال دیدگاه یک حساب کاربری ایجاد کنید یا وارد حساب خود شوید

برای اینکه بتوانید دیدگاهی ارسال کنید نیاز دارید که کاربر سایت شوید

ایجاد یک حساب کاربری

برای حساب کاربری جدید در سایت ما ثبت نام کنید. عضویت خیلی ساده است !


ثبت نام یک حساب کاربری جدید

ورود به حساب کاربری

دارای حساب کاربری هستید؟ از اینجا وارد شوید


ورود به حساب کاربری

  • چه کسانی در حال بازدید هستند؟   0 کاربر

    هیچ کاربر عضوی،در حال مشاهده این صفحه نیست.