رفتن به مطلب

کسی میتونه کمک کنه؟


پست های پیشنهاد شده

سلام دوستان

نمیدونم چرا یهو سایت به این وضع در اومده

 

Warning: require() [ لینک ها تنها برای اعضای سایت قابل نمایش است. ]: Unable to access /home4/samsungddl/public_html/wp-includes/nav-menu.php in /home4/samsungddl/public_html/wp-settings.php on line 153

 

Warning: require(/home4/samsungddl/public_html/wp-includes/nav-menu.php) [ لینک ها تنها برای اعضای سایت قابل نمایش است. ]: failed to open stream: No such file or directory in /home4/samsungddl/public_html/wp-settings.php on line153

 

Warning: require() [ لینک ها تنها برای اعضای سایت قابل نمایش است. ]: Unable to access /home4/samsungddl/public_html/wp-includes/nav-menu.php in /home4/samsungddl/public_html/wp-settings.php on line 153

 

Warning: require(/home4/samsungddl/public_html/wp-includes/nav-menu.php) [ لینک ها تنها برای اعضای سایت قابل نمایش است. ]: failed to open stream: No such file or directory in /home4/samsungddl/public_html/wp-settings.php on line153

 

Fatal error: require() [ لینک ها تنها برای اعضای سایت قابل نمایش است. ]: Failed opening required '/home4/samsungddl/public_html/wp-includes/nav-menu.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in/home4/samsungddl/public_html/wp-settings.php on line 153

باید چیکار کنم؟

لینک ارسال
به اشتراک گذاری در سایت های دیگر

همون فایلی که تو ارور نوشته رو نمیتونه پیدا کنه که بازش کنه یا شاید اسمشو عوض کردی برو به همین ادرسی که تو ارور نوشته

لینک ارسال
به اشتراک گذاری در سایت های دیگر
  • مدیر انجمن

سلام .

 

این مشکل کمی پیچیده هستش . مربوط میشه به محدودیت هاست و عدم دسترسی به فایل nav-menu.php

 

در سایت های وردپرسی خارجی دنبال این مشکل گشتم اما راه حتمی و قطعی برای حل این مشکل رو نداده بودند . فقط چندین راه بود که انجامش نیاز به زمان یا دسترسی داره که من می گم اونا رو و شما تست کنید :

 

 

1. ابتدا تمامی افزونه هاتون رو غیرفعال کنید . (از پیشخوان غیرفعال بشه که چه بهتر) اما اگه دسترسی به پیشخوان نداشتید ، به فایل منیجر > wp-content برید > و پوشه ی plugins رو به plugins0 تغییر نام بدید .

 

2. وردپرس فارسی (آخرین نسخه) رو دریافت کنید و محتویات پوشه ی wp-includes و wp-admin رو داخل فایل منیجر هاستتون با فایل های موجود جایگزین کنید .

 

3. تست کنید مشکل رفع شده یا خیر . اگه تا این جا ارور برطرف شد ، مشکل از پلاگین هاتون بوده . وارد پیشخوان بشید و تک تک اون ها رو فعال کنید و بررسی کنید پس از فعال کردن کدوم افزونه ارور دریافت می کنید . اون افزونه رو به کل پاک کنید و جایگزینی برای اون در نظر بگیرید .

 

4. اگه مشکل همچنان پابرجا بود : وارد wp-content در فایل منیجر بشید و پوشه ی themes رو به themes0 تغییر نام بدید .

 

5. مجددا بررسی کنید . با تغییر قالب ، ارور ها باید رفع بشن ، اما اگه باز هم رفع نشد :

 

 

6. کد زیر رو در فایل php.ini فایل منیجرتون قرار بدید :

 

 

suhosin.post.max_vars = 5000suhosin.request.max_vars = 5000

 

 

اگر عدد 5000 کاری نکرد ، عدد رو به 3000 تغییر بدید و تست کنید .

 

 

7. اگر به پیشخوان دسترسی پیدا کردید ، پیوندهای یکتا رو روی حالت پیش فرض قرار بدید .

 

 

 

 

+ یک راه دیگه هم هست و اونم اینه که در فایل wp-settings.php برید و کد زیر رو حذف کنید !

 

 

require( ABSPATH . WPINC . '/nav-menu.php' );

 

 

این کد ، فایل nav-menu.php رو فراخوانی می کنه که گاهی اوقات به دلیل تعداد درخواست های لود این فایل ، هاستتون به صورت خودکار دسترسی به این فایل رو منع می کنه .

 

یا اینکه به مسیر فایل nav-menu.php برید و بررسی کنید فایل موجود هست یا خیر . اگر نبود ، فایل رو پیش از اینکه عملیات های بالا رو انجام بدید ، مجددا آپلود کنید . همانطور که گفتم در پی افزایش فشار این فایل ، توسط هاست حذف میشه (به صورت خودکار)

  • Like 3
لینک ارسال
به اشتراک گذاری در سایت های دیگر

آقا دمت گرم

مشکل حل شد

وردپرس فارسی رو دوباره ریختم و محتویات پوشه آپلود و پلاگین و تم رو بهش انتقال دادم و همون آدرس دیتابیس قبلی رو بهش دادم درست شد!!!!

واقعا عجیب بود!

لینک ارسال
به اشتراک گذاری در سایت های دیگر
مهمان
این موضوع برای عدم ارسال قفل گردیده است.
×
×
  • اضافه کردن...